Immuta SaaS Service - Impacting Event Notification

Incident Report for Immuta

Resolved

This incident has been resolved.
Posted May 21, 2025 - 01:22 UTC

Monitoring

We've implemented a fix and are monitoring the results. Some jobs will restart as systems return to normal.
Posted May 21, 2025 - 00:40 UTC

Investigating

We want to inform you that the Immuta SaaS platform is currently experiencing a partial outage due to a performance-impacting event. This issue is impacting Marketplace along with domains and identification. While some users may not be impacted, others may experience intermittent issues.

Our team is actively working to resolve the issue and restore service to a fully operational state. We apologize for any inconvenience this may cause and appreciate your patience during this time.

If you have any questions regarding this issue, please contact our Immuta Customer Support team by opening a ticket at https://support.immuta.com or in the event of an emergency, sending an email to emergency-support@immuta.com.
Posted May 21, 2025 - 00:11 UTC
This incident affected: APAC Regions (APAC Marketplace, APAC Data Governance), EU Regions (EU Marketplace, EU Data Governance), and Americas Regions (Americas Marketplace, Americas Data Governance).