A fix have been deployed and we are monitoring the progress. We will work on identifying any jobs that failed and need to be requeued.
Posted Mar 02, 2026 - 21:52 UTC
Update
Our engineering team has identified the root cause and is actively working on a fix to restore full functionality. All other platform services remain operational.
Posted Mar 02, 2026 - 20:51 UTC
Identified
We are currently investigating a service disruption affecting the Identification and Classification services within the Immuta SaaS platform.
What this means for you: Automatic data detection and column tagging may fail during this period. You may encounter the following error message: “Latest Identification run not successful. Automatic data detection and column tagging did not occur.”
Current Status: Our engineering team has identified the root cause and is actively working on a fix to restore full functionality. All other platform services remain operational.
We apologize for the interruption. For urgent assistance, please email emergency-support@immuta.com or open a ticket at support.immuta.com.
Posted Mar 02, 2026 - 20:43 UTC
This incident affected: APAC Regions (APAC Governance App), EU Regions (EU Governance App), and Americas Regions (Americas Governance App).