Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2024 - 16:00 UTC
Scheduled
This is to inform you that we will be performing a scheduled deployment of the Immuta SaaS solution.
Deployment Information: - Zero Downtime: We have implemented measures to ensure continuous service availability throughout the deployment process. You should experience no interruption in system access or functionality. - Maintenance and Improvements: This deployment includes routine software updates and fixes aimed at enhancing solution performance and stability. - Feature Updates: For details on any new features or impactful changes, please refer to the "What's New?" section within the Immuta application or consult our online documentation.
We appreciate your continued trust in Immuta.
Posted Nov 11, 2024 - 15:05 UTC
This scheduled maintenance affected: Immuta SaaS Hosting (North America, Europe, Asia Pacific).